Неправильная раскладка клавиатуры на клиентском ПК при использовании синергии

Я только что установил Ubuntu 11.10 на свой новый компьютер, старый (все еще главный компьютер) - Ubuntu 10.04. Оба компьютера используют раскладку клавиатуры «Испанский LAm», единственное отличие состоит в том, что новая клавиатура ПК имеет несколько мультимедийных клавиш, но их конфигурации одинаковы и хорошо работают на каждом ПК.

Но когда я использую синергию для использования основной клавиатуры на клиентском ПК (11.10), раскладка клавиатуры выглядит как «Английская (США)» или другая, но не «Испанский LAm», в то время как настройки на обоих ПК остаются как "испанский лам". Другая клавиатура, подключенная кабелем к клиентскому ПК, хорошо работает с испанской раскладкой даже при использовании синергии.

Есть идеи, как это исправить?

8
задан 16.12.2019, 03:28

4 ответа

  1. Найдите «Раскладку клавиатуры» и откройте ее.

  2. Используйте знак «плюс» в левом нижнем углу экрана, чтобы добавить раскладку клавиатуры «Английский (США)».

  3. Перезапустите синергию

Это сработало для меня. (Ubuntu 11.10 64-bit)

0
ответ дан 16.12.2019, 03:28
  • 1
    У меня есть та же проблема в 12,04, хотя с норвежской контурной картой и Windows 7 на стороне сервера. Это раньше работало безупречно на меня в 11,10 с той же установкой. Предложение в этом ответе не работает на меня. – fullofsquirrels 16.12.2019, 03:28

В моем случае синергия выглядит просто, чтобы игнорировать фактическую раскладку клавиатуры, но помогает, если я установлю ее после запуска синергии.

synergyc myhost
setxkbmap us -option grp:alt_shift_toggle

Вы найдете правильные значения для setxkbmap аргументов в файле /etc/default/keyboard. Вместо us установите значение XKBLAYOUT и передайте значение от XKBOPTIONS до -options.

Вы можете использовать этот простой скрипт, чтобы сделать это автоматически:

#!/bin/sh

. /etc/default/keyboard
synergyc $1
setxkbmap $XKBLAYOUT -option "$XKBOPTIONS" -model "$XKBMODEL" \
                     -variant "$XKBVARIANT"

Сохраните его как mysynergyc, установите правильные разрешения (chmod 755 mysynergyc) и затем запустите как обычно вместо synergyc. [ 1114]

0
ответ дан 16.12.2019, 03:29

У меня была такая же проблема с конфигурацией моего сервера Windows / клиента Ubuntu. На работе у меня была другая установка, и она работала как сон.

В качестве обходного пути к клиенту Ubuntu добавлена ​​еще одна таблица ключей. Затем, используя Synergy, переключил раскладку клавиатуры с en на de, и она начала работать.

0
ответ дан 16.12.2019, 03:29

Остановите сервер синергии, сбросьте раскладку клавиатуры на сервере, затем перезапустите синергию, чтобы решить проблему в моей ситуации. Оригинальная ссылка здесь: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580504#15

0
ответ дан 16.12.2019, 03:30

Теги

Похожие вопросы