Почему Ubuntu nvidia-current не поддерживает более поздние проприетарные драйверы для релизов LTS?

, например, в моей системе Lucid 10.04 LTS мне пришлось удалить проприетарные драйверы ubuntu и вручную установить драйверы с nvidia.com для обновленного видеоадаптера, чтобы система работала.

Это, по-видимому, не согласуется с политикой MS или с версиями Ubuntu wiki

«nvidia-graphics-drivers» , опубликованными в Ubuntu

Precise (295.20-0ubuntu1): restricted/misc 
Lucid-updates (195.36.24-0ubuntu1~10.04.1): restricted/misc 
Oneiric (280.13-0ubuntu6): restricted/misc 
Natty (270.41.06-0ubuntu1): restricted/misc 
Maverick (260.19.06-0ubuntu1): restricted/misc 
Lucid (195.36.15-0ubuntu2): restricted/misc 

Этот список устарел, в моей системе Maverick установлено 295.20-0ubuntu1 ~ maverick ~ xup1.

Обновление: версии от 17 октября 2012 г.

Quantal (304.51.really.304.43-0ubuntu1): restricted/misc 
Lucid-updates (195.36.24-0ubuntu1~10.04.3): restricted/misc 
Precise-updates (295.40-0ubuntu1.1): restricted/misc 
Oneiric-updates (280.13-0ubuntu6.2): restricted/misc 
Natty-updates (270.41.06-0ubuntu1.2): restricted/misc 
Lucid-security (195.36.24-0ubuntu1~10.04.3): restricted/misc 
Natty-security (270.41.06-0ubuntu1.2): restricted/misc 
Oneiric-security (280.13-0ubuntu6.2): restricted/misc 
Precise-security (295.40-0ubuntu1.1): restricted/misc 
Precise (295.40-0ubuntu1): restricted/misc 
Oneiric (280.13-0ubuntu6): restricted/misc 
Natty (270.41.06-0ubuntu1): restricted/misc 
Lucid (195.36.15-0ubuntu2): restricted/misc 

2
задан 07.02.2020, 11:39

4 ответа

Почему LTS не поддерживает последние версии драйверов ...

LTS направлена ​​на обеспечение стабильной системы для самого большого круга людей и систем.

Таким образом, если вы ищете последнюю версию - посмотрите на следующую версию разработки и / или установите PPA или скомпилируйте свой собственный код. Следует ожидать потенциальной нестабильности - так что это не для слабонервных.

Хорошие новости ...

В связи с тем, что Canonical сейчас фокусируется на выпуске новейших игр для 12.04 и выше; более новые выпуски, экспериментальные пакеты теперь доступны.

Ключевая фраза - экспериментальная - они являются самыми последними (или почти последними) прямо от ключевых поставщиков графики. Они были протестированы этими поставщиками и должны быть выпущены для бета-тестирования. Поэтому вам нужно тщательно обдумать это, если вы не уверены, что можете исправить проблемы с черным экраном.

Nvidia

Более новые - более экспериментальные пакеты должны быть доступны для 12.04 и будущих выпусков.

Эти пакеты помечены nvidia-experimental - на момент написания, пакет nvidia-experimental-304. Чтобы найти экспериментальный пакет, введите nvidia-experimental и нажмите TAB для автозаполнения имени.

, т.е.

sudo apt-get install nvidia-experimental-304

При выпуске канонические первые выпуски в репозиторий proposed, прежде чем они попадают в основные репозитории - следовательно, вы можете включить репозиторий proposed в update-manager - settings

По-видимому, Каноническая цель - получить последнюю версию драйвера в течение 3 дней после выпуска Nvidia для публичной бета-версии.

AMD

На данный момент предложение получить последние версии драйверов в настоящее время не определено.

Вам нужно будет посмотреть на сайте AMD последние версии драйверов самостоятельно.

Intel

Последние драйверы Intel должны быть доступны через x-updates PPA

Для установки:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get upgrade

Для дополнительную информацию и источник этого ответа см. в превосходном блоге Брайса Харрингтона .

0
ответ дан 07.02.2020, 11:39

Во-первых, Ubuntu Wiki, как и почти любая вики, редактируется и поддерживается сообществом. Он может легко устареть, и если вы найдете какую-либо устаревшую информацию, рекомендуем вам внести изменения.

Во-вторых, основной проблемой поддержки последних версий драйверов в старых версиях является поддержка более старых ядер и версий диспетчера отображения X. По мере старения становится все труднее поддерживать совместимость, и в конечном итоге разработчикам приходится прекращать поддержку некоторых старых программ, чтобы внедрять новые функции, устранять некоторые ошибки и поддерживать новые API и т. Д. Вот почему вы обнаружит, что, несмотря на то, что 10.04 является выпуском LTS, у него не всегда есть возможность получить новейшее и «лучшее» программное обеспечение и драйверы. К счастью, 12.04, следующий выпуск LTS, позволит вам запускать более поздние версии драйверов NVidia, так что вы сможете обновиться до него, когда он будет доступен.

0
ответ дан 07.02.2020, 11:40

В выпусках LTS всегда существует напряжение между поддержкой новейшего оборудования и обеспечением работоспособности существующего оборудования.

Для ядра 10.04 это поддерживается ядрами linux-backports-* - они являются ядрами текущего выпуска разработки, поэтому включают самую актуальную аппаратную поддержку. Важно отметить, что они выбраны в - если они вам нужны, то вы можете установить их, но если ваше оборудование работало в версии 10.04, мы можем быть гораздо увереннее, что ваше оборудование будет продолжать работать с настройками по умолчанию ( 2.6.32) ядро, чем с linux-backports-*.

Для Ubuntu 12.04 существуют аналогичные пакеты nvidia-current-updates и fglrx-updates. Мы можем обновлять их, не опасаясь поломки оборудования, которое работало при выпуске, и пользователи, которые в них нуждаются, могут подписаться.

Серьезные обновления драйверов - например, от драйверов серии 195 до драйверов серии 295 - несут в себе серьезную опасность сбоя при работе вещей, которые в настоящее время работают. Это неприемлемо для LTS: люди используют LTS точно, поэтому они не получают серьезных изменений. Решение nvidia-current-updates позволяет избежать этой проблемы.

0
ответ дан 07.02.2020, 11:40

12.04 поддержка nvidia-173 не работает, поскольку в ней отсутствует необходимая поддержка ABI. Драйвер nvidia-current поддерживает, но не поддерживает серию fx 5 (у меня это nvidia fx 5500), так что пока прощайте с 3D-акселератором. grrrr

(ручная установка драйверов (текущая или 173) также не работает, так как первая на самом деле не работает на fx5500, а вторая не имеет поддержки ABI). 111]

0
ответ дан 07.02.2020, 11:41

Теги

Похожие вопросы