Это нормально, что compiz потребляет 40% моего процессора без запуска других программ?

Когда у меня нет запущенных других программ, compiz занимает как минимум 40% моего процессора.
Это нормально? Если это нормально, могу ли я заставить эту программу брать меньший процент?

29
задан 15.01.2020, 19:04

8 ответов

Я понял ту же проблему в Ubuntu 15.04. У моего ноутбука была большая задержка, и я увидел, что загрузка процессора всегда составляла до 25%. Сначала я искал драйверы, но в конце концов обнаружил, что compiz падает до 3%, как только веб-приложение не открывается. Раньше я использовал твиттер и фейсбук с нативными веб-приложениями (встроенными в оксид).

Так как я просто использую Firefox, Compiz не поднимается выше 5% CPU.

Надеюсь, это поможет.

0
ответ дан 15.01.2020, 19:05

Я понял, что на моем ноутбуке с графическим процессором NVIDIA 8600M GS и фирменным пакетом драйверов nvidia-340 compiz всегда использовал весь процессор, который он мог получить от одного ядра. Если на моем компьютере не выполняется никаких других действий, это означает, что на одном ядре значение близко к 100%, а на другом - все остальные нагрузки. Топ также сообщает почти 100% для самого compiz.

Конечно, кажется, что один поток остается активным, поэтому на четырехъядерном ПК вы получите 25% нагрузки и 16% на 6-ядерном i7.

Весь компьютер был вялым до такой степени, что для ввода текста.

Я запустил «pilotes дополнения» (настройку французского языка), встроенный интерфейс Ubuntu, который устанавливает проприетарный драйвер, и мне предложили выбор версий драйверов NVIDIA, а также nouveau, драйвера с открытым исходным кодом.

В самом конце списка я заметил «nvidia-340-update», то есть тот же самый проприетарный драйвер NVIDIA 340.96, и решил попробовать. 8600M GS не поддерживается в более поздних выпусках драйверов. Я позволил установщику скомпилировать все, перезагрузить, когда об этом попросят, и высокая загрузка ЦП из compiz исчезла!

Если это работает для вас, это решение лучше подходит для инфраструктуры linux-ограниченных модулей, чем для управления драйвером NVIDIA вручную. Он заменяет nvidia-340 на nvidia-340-update.

0
ответ дан 15.01.2020, 19:06
  1. Установить compizconfig-settings-manager. Запустите его, набрав ccsm в тире.

  2. В главном окне приложения нажмите на нижнюю ссылку с меткой Предпочтения .

  3. На вкладке «Профиль» нажмите кнопку Сброс к значению по умолчанию .

  4. Выйдите из системы и войдите снова.

Надеюсь, что это поможет

picture of Profile tab

0
ответ дан 15.01.2020, 19:06
  • 1
    Don' t делают это с 14,10. Я don' t знают о более ранней версии Ubuntu, но я просто сделал это, и это заставило меня терять свои границы окна и меню единицы. Перезагрузка didn' t фиксируют его, у меня был к плагину свой телефон, чтобы заставить окно файлов открываться, затем просматривать к терминальному приложению, чтобы открыть его, затем выполнить пару команд для решения проблемы. – Rajesh Darapu 15.01.2020, 19:07

Была такая же проблема. Compiz постоянно на уровне около 40% (AMD CPU, ATI 58xx, 12.04). Затем я последовал этому посту https://askubuntu.com/a/127310/26508 и загрузка ЦП упала ниже 10%. Надеюсь, это поможет.

РЕДАКТИРУЙТЕ с помощью выражений:

Просто создайте резервную копию (переименуйте) каталогов ~/.compiz-1 и ~/.config/compiz-1 и разрешите их повторное создание с настройками по умолчанию (вам необходимо выйти из системы). и войдите снова).

mv ~/.compiz-1 ~/.compiz-1.BACKUP
mv ~/.config/compiz-1 ~/config/.compiz-1.BACKUP

После перезапуска и подтверждения того, что все работает, как ожидалось, вы можете просто удалить эти резервные копии (если у вас их нет).

rm -Rfv ~/.compiz-1.BACKUP
rm -Rfv ~/config/.compiz-1.BACKUP

Это помогает сделать unity --reset также

0
ответ дан 15.01.2020, 19:07
  • 1
    О, это было опечаткой. Я имел в виду ответ. помещение ответа непосредственно здесь может быть более полезным – saurabh kumar 15.01.2020, 19:07
  • 2
    Какой фактический вопрос? – Tebo 15.01.2020, 19:07
  • 3
    Можно ли поместить фактический ответ здесь. – Charles Bretana 15.01.2020, 19:08

У меня была та же проблема, что загрузка процессора возросла до 70 ~ 80%, и это долго расстраивало меня после обновления до 12.04 с 10.04.

И сбросить настройки compiz на значения по умолчанию или удалить ~/.compiz-1 & amp; ~/.config/compiz-1 папки не работали.

Но после того, как я снял флажок «Синхронизировать с VBlank» в OpenGL в ccsm (CompizConfig Settings Manager), загрузка ЦП сразу упала до 1%.

Надеюсь, это поможет вам и другим парням ...

Извините за плохое выражение лица (я студент из Китая).

0
ответ дан 15.01.2020, 19:07
  • 1
    Стоп, это помогло много здесь также. Это, оказывается, находится в системе, которая использует драйверы закрытого исходного кода Nvidia? – Tom W 15.01.2020, 19:07
  • 2
    Спасибо, студент из Китая:) Синхронизация к Vblank помогла мне также. Предупреждение: После Сброса к значениям по умолчанию я должен был измениться на консоль и ввести " единица - reset" и удалите галочку у Синхронизации к Vblank снова. – Robert Harvey 15.01.2020, 19:08

Редактировать: Начиная с Ubuntu 12.10, это больше не вариант, так как Unity-2D был отброшен с количественным.

У меня такие же проблемы с использованием процессора из-за compiz. Мой обходной путь - переключить сессию с Ubuntu на Ubuntu 2D.

ubuntu 2d

0
ответ дан 15.01.2020, 19:07
  • 1
    Я на самом деле сделал это вскоре после выяснения, и оно удалось действительно хорошо для меня. Everything' s намного более гладкий. – Razzie 15.01.2020, 19:08
  • 2
    Это не нормально, и переключающийся на 2D Единицу, когда на современной высококачественной машине не решение. Разработчики должны действительно разработать это, поскольку это является очень раздражающим. – Evan Hu 15.01.2020, 19:08
  • 3
    @ECII, который я согласовываю с Вами, но в то время как они фиксируют его, 2-я единица, мог быть обходным решением для проблемы. – Maziyar 15.01.2020, 19:08
  • 4
    Как это может быть решением?. OP желает использовать compiz с меньшим количеством использований ЦП. В единице, 2-й нет никакого compiz. – Chriss 15.01.2020, 19:09

В новой версии Compiz и плагина Unity внесены серьезные изменения, которые заставляют его вести себя по-разному. В моем собственном случае у меня было для сброса настроек compiz по умолчанию , чтобы заставить его работать должным образом после обновления до 12.04.

У меня есть карта ATI Radeon HD5750, и я действительно отметил значительное улучшение производительности (после исправления compiz) по сравнению с 11.10.

0
ответ дан 15.01.2020, 19:08

по-видимому, есть ошибка с базой карт ATI на этом сайте: http://followthegeeks.com/compiz-is-consuming-too-much-cpu-heres-the-solution/ [115 ]

на основе этого сайта есть несколько шагов:

  1. установить compizconfig-settings-manager (CCSM)
  2. перейдите к opengl, затем измените Texture Filter на Fast и снимите флажок sync VBlank
  3. закройте CCSM, затем перезапустите проверку ubuntu

на системном мониторе, надеюсь, что compiz больше не понадобится много CPU.

0
ответ дан 15.01.2020, 19:09

Теги

Похожие вопросы