Почему я получаю & ldquo; неудовлетворенные зависимости & rdquo; ошибка при попытке установить WINE? [Дубликат]

На этот вопрос уже есть ответ:

При попытке установить WINE (sudo apt-get install wine) я получаю следующую ошибку:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Google действительно говорит мне, что, очевидно, это как-то связано с ia32-libs , но я не могу узнать, как это сделать, чтобы исправить зависимости или мне нужно (вручную?) установить что-то еще.

Я добавил ppa:ubuntu-wine/ppa в свои репозитории.

sudo apt-get install wine1.5 дает мне

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.4-0ubuntu1~ppa1~precise1+pulse17)

sudo apt-get install wine1.5-i386 дает мне

The following packages have unmet dependencies:
 wine1.5-i386:i386 : Depends: libgphoto2-2:i386 (>= 2.4.10.1) but it is not going to be installed
                     Depends: libgphoto2-port0:i386 (>= 2.4.10.1) but it is not going to be installed
                     Recommends: gettext:i386 but it is not going to be installed
                     Recommends: libsane:i386 but it is not going to be installed

Любая помощь будет оценена. Спасибо.

2
задан 30.04.2014, 04:59

4 ответа

У меня была похожая проблема с нарушенными зависимостями при попытке установить wine и acroread, а также с жалобой при попытке установить ia32-libs-multiarch, сразу после обновления до 12.04 с 11.04 (проходящего через 11.10). Кажется, что некоторые ppa, которые я имел в 11.04, установили новые версии приложений в системе. После обновления остатки этих приложений, казалось, запутались в зависимостях.

Решение, которое, кажется, работает (до сих пор), было найдено на немецкой доске Ubuntu ( http://forum.ubuntuusers.de , сообщения от пользователя Lasall):

Сначала требуется понижение рейтинга до следующего: создайте файл «предпочтений»:

sudo vi /etc/apt/preferences

и вставьте следующие строки:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

введите :wq, чтобы записать файл , Приоритет пин-кода должен быть больше 1000.

Затем вы можете понизить версию приложений-нарушителей с помощью:

sudo apt-get dist-upgrade

Затем вы можете установить пакеты с жалобами на зависимости, такие как sudo apt-get install ia32-libs-multiarch или sudo apt-get install ia32-libs.

Наконец, вам следует удалить файл, который вы только что создали:

sudo rm /etc/apt/preferences

, потому что иначе не будет найдено никаких новых обновлений.

Надеюсь, это вам тоже поможет!

3
ответ дан 22.10.2019, 16:16

Попробуйте установить Wine с помощью Ubuntu Software Center, чтобы увидеть, решена ли проблема.

Вы можете найти некоторые полезные справочные ресурсы для Wine на www.winehq.org/help/, а также узнать больше об альтернативах Wine на winehq.org

0
ответ дан 22.10.2019, 16:16

Что мне сработало в 13.04 64-битном, так это ответ Дэвида Лео с небольшим изменением базовых файлов:

Пакет: *
Pin: release a = raring * Pin-Priority: 2012

0
ответ дан 22.10.2019, 16:16

Это то, что мне помогло в Ubuntu 12.04.2 LTS

Run

gksu gedit /etc/apt/preferences.d/base-files

Paste & amp; Сохранить

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Понижение рейтинга приложений, вызывающее ошибку

sudo apt-get dist-upgrade

Теперь мы можем установить Wine

sudo apt-get install wine

Наконец, удалите созданный вами файл

[114 ]
1
ответ дан 22.10.2019, 16:16

Теги

Похожие вопросы