Модули ядра VMWare не будут компилироваться или обновляться в Ubuntu 12.04

Обновление модуля ядра требовалось при открытии клиента VMWare (vmplayer), после чего возникает следующая ошибка. Любая идея будет оценена.

Unable to start services.
See log file /tmp/vmware-root/setup-NNN.log for details    (Note: NNN looks like random numbers)

В графическом интерфейсе, отображающем ход обновления, на «Virtual Netowork Device» отображается красный флаг. Содержимое файла .log находится здесь: http://pastebin.com/wEKT5UHf

На этой странице предлагается установить linux-headers-generic и build-essential, которые уже установлен на моем (таким образом, ничего хорошего).

Это может быть 1-е выполнение vmplayer на моей машине, так как я обновился до Ubuntu 12.04 с 11.10.

Среда: VMware Player 4.0.3 build-703057

3
задан 12.01.2020, 17:26

3 ответа

У меня была та же проблема, что VMWare не работал после обновления до Ubuntu 12.04. Вместо установки патча с ненадежной страницы, я просто скачал и установил последнюю версию VMware-Player-5.0.0 с VMWare-Page:

https://my.vmware.com/ web / vmware / free # desktop_end_user_computing / vmware_player / 5_0

Пока что, похоже, все работает правильно. Я надеюсь, что это нормально и для вас.

2
ответ дан 12.01.2020, 17:26
  • 1
    В то время как @izx' решение работало отлично (особенно в тот момент, когда я задал этот вопрос), я чувствую, что это более идеально и работало просто великолепно на моей машине. Таким образом, я повторно выбрал это в качестве ответа. – jcubic 12.01.2020, 17:27

VMWare отстает от времени, и модули VMWare не будут компилироваться по умолчанию в ядре 3.2, которое использует Ubuntu 12.04.

Пожалуйста, используйте патч, доступный в этом сообщении в блоге , а затем попробуйте снова скомпилировать.

Я могу подтвердить, что патч сработал для меня как на VMWare Player 4.x, так и на Workstation 8.x в Ubuntu 12.04.

2
ответ дан 12.01.2020, 17:27
  • 1
    На последующей ноте Это происходит с 4.0.4, но тот же патч был эффективным. – Christophe 12.01.2020, 17:27
  • 2
    Это работает прекрасное. Как я прокомментировал в том же блоге, только настройте, мне было нужно, должен был изменить plreqver с корректным vmplayer версия, в данном .sh файле в патче ( goo.gl/fF4Yk). Спасибо! – B.F. 12.01.2020, 17:28

Это работало и для меня, меняя переменную plreqver только на правильную версию (в моем случае 4.0.3), как упомянуто выше.

Это мои системные версии:

  • vmware-player 4.0.3.703057

  • Выпуск 12.04 (точный) 32-разрядный

  • Linux 3.2.0-24-generic-pae

0
ответ дан 12.01.2020, 17:27

Теги

Похожие вопросы