Обновление драйвера nVidia до 295.53 в 12.04

Я сам собираю ядра Linux. Мне нравится возиться с настройками, чтобы попытаться максимально уменьшить сборку.

Но здесь есть проблема: версия драйверов nVidia в oneric слишком мала для поддержки Linux 3.4 (см. Эту ошибку: https://launchpad.net/bugs/993506 )

Итак, чтобы использовать Linux 3.4 на моем компьютере, у меня есть несколько вариантов:

1) Использовать хак с исходным кодом (переместить файл из arm / в x86 /) (я бы предпочел, поскольку это может создать проблемы позже)

2) Установите драйвер с помощью установщика nVidia (Не очень хороший вариант, поскольку могут возникнуть конфликты пакетов (например, warzone2100 не будет установлен, поскольку пакет драйвера не установлен)) [ 116]

3) Найдите какой-нибудь способ установки пакета ubuntu 295.53 в этой системе (либо установив пакет непосредственно по ссылке панели запуска, собрав пакет или используя backports (предпочтительно))

Итак, я Я предполагаю, что № 3 - самый правильный способ сделать это, и если так, то какой будет лучший способ тогда?

PS: я не смущаюсь по поводу автоматического обновления .

0
задан 06.02.2020, 13:26

3 ответа

Не думаю, что вам нужно собирать драйвер самостоятельно, попробуйте использовать ppa swat-x

https://launchpad.net/~ubuntu-x-swat/+archive/x -updates /? field.series_filter = oneiric

другими словами:

  1. sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
  2. sudo apt-get update
  3. [ 112]
2
ответ дан 06.02.2020, 13:29
  • 1
    Просто обнаруженный, что перед обновлением..... Спасибо! – Chris Marisic 06.02.2020, 13:29

3 является наиболее подходящим вариантом.

  1. Временно добавить precise исходное репо в sources.list
  2. apt-get source 295.52-driver-package-whatever-that-is
  3. Попробуйте собрать с dpkg-buildpackage -us -uc
  4. Успешно и получить пакеты deb или получите сообщения об ошибках зависимости, в этом случае попытайтесь разрешить и goto 3.
1
ответ дан 06.02.2020, 13:27
  • 1
    Нет - просмотр архива вручную ( au.archive.ubuntu.com/ubuntu/pool/restricted/n/… ), показывает тот же исходный файл, что я загрузил ранее (просто .tar.gz файлов выполнения.) – agold 06.02.2020, 13:27
  • 2
    Я пытался загрузить источник с панели запуска, но это просто имело .run файлы, которые распределяет nv. Этот источник отличался бы? – Pytry 06.02.2020, 13:28
  • 3
    Извините, это походит на собственные драйверы, в который. se просто устанавливают точный debs/binaries и обновление. " source" конечно, не создаст. – sarnold 06.02.2020, 13:28
  • 4
    Я посмотрел на ошибку, it' s общая pm_message проблема заголовка (я создаю пользовательские ядра также). Обходное решение прекрасно - версии руки не являются проблемой, так как это - в основном проблема переименования файла. Поочередно, попробуйте deb от nvidia-graphics-drivers-updates (295.53-0ubuntu1) quantal – sarnold 06.02.2020, 13:29
  • 5
    Также знаменитый - различный файл подразумевает, что существует стандарт debain/control файл и такой, но в архиве нет ни одного. archive' s md5 соответствия тот из того на панели запуска. – eightyfive 06.02.2020, 13:29

Добавьте ppa:ubuntu-x-swat/q-lts-backport и ppa:ubuntu-x-swat/x-updates, обновите, установите ядро, вручную загрузите nvidia-current-updates_295.53-0ubuntu1_amd64.deb для izx ... сделано и сделано.

0
ответ дан 06.02.2020, 13:28
  • 1
    I' d рекомендуют редактировать Ваш ответ для включения информации о том, как выполнить каждый из этих шагов. – Community 06.02.2020, 13:28

Теги

Похожие вопросы