Не удалось установить Chrome в Ubuntu 12.04

Чтобы обе клавиши Shift kbd> вместе переключали Caps Lock kbd> (см. Вывод команды grep 'shift:both_capslock' /usr/share/X11/xkb/rules/xorg.lst):

setxkbmap -option shift:both_capslock

Для переключения Caps Lock kbd> для Alt Gr kbd>:

xmodmap -e "keycode 66 = Alt_R Meta_R Alt_R Meta_R"

Для переключения раскладки с помощью сочетания клавиш Alt kbd> + Shift kbd> см. следующий пост, если вы используете Ubuntu 13.10:

Для Ubuntu 13.04 и старше см .:

2
задан 02.02.2020, 17:22

3 ответа

Я не уверен на 100% в этом, но вот мое предположение: chrome зависит от xdg-utils >= 1.0.2, но вы установили 1.1.0~rc1-2ubuntu6 (по крайней мере, у меня это на моем linux mint 13 64 bit). [113 ]

Где-то есть недоразумение, которое заставляет поверить, что ваша версия 1.1.0 rc1 более ранняя, чем 1.0.2, поэтому не удовлетворяет зависимость.

Если я прав, проблема исчезнет, ​​как только xdg-utils получит окончательный номер версии. Тем временем я лично наслаждаюсь безупречно работающим Chrome, установленным с dpkg -i --force-depend.

-2
ответ дан 02.02.2020, 17:22

Как показал комментарий maximd к вашему вопросу, та же ошибка, что и у вас, возникает при попытке установить 32-битный Chrome в 64-битной системе Ubuntu. Это сообщение i386 ошибка происходит всегда, когда это проблема архитектуры. Напротив, сегодня я успешно установил тот же 32-битный deb в 32-битной системе, поэтому проблема не в плохой версии Chrome.

Ошибка архитектуры хорошо известна, как задокументировано в аналогичном вопросе в Superuser, где обсуждаются аналогичные проблемы зависимости. Из-за функции multiarch в Ubuntu (которая позволяет пользователю устанавливать 32-битные пакеты в 64-битных системах) подобные ошибки в настоящее время встречаются не очень регулярно, но все же возможны. Иногда по-прежнему необходимо использовать 64-разрядную версию пакета.

Нет смысла принудительно устанавливать что-то вроде sudo dpkg -i --force /location/of/deb, так как это не решит проблемы с зависимостями, поэтому я должен просто удалить частичную установку Chrome с помощью sudo apt-get install -f и установите 64-битную deb с сайта Google Chrome с помощью gdebi или Software Center, что также разрешит зависимости.

3
ответ дан 02.02.2020, 17:23

Это вызвано ошибкой # 992797 .

Это не из-за номера версии, а из-за отсутствия поддержки Multi-Arch в пакете xdg-utils. Мне удалось успешно установить Chrome без --force-depends, добавив Multi-Arch: foreign в файл DEBIAN/control для xdg-utils и пересобрав этот пакет с помощью dpkg-deb, но, конечно, это все еще оставляет apt-get dist-upgrade неработоспособным, поскольку репозитории имеют ломаная версия.

Обновление: если вы добавите эпоху в версию, она исправит apt-get. Таким образом, полный обходной путь:

apt-get download xdg-utils
dpkg-deb -R xdg-utils*.deb xdg-utils
patch xdg-utils/DEBIAN/control # (paste in the patch below)
fakeroot dpkg-deb --build xdg-utils xdg-utils-hacked.deb
sudo dpkg -i xdg-utils-hacked.deb

патч:

--- xdg-utils.orig/DEBIAN/control   2011-10-04 00:49:41.000000000 -0400
+++ xdg-utils/DEBIAN/control    2012-11-30 16:24:15.365170233 -0500
@@ -1,6 +1,7 @@
 Package: xdg-utils
-Version: 1.1.0~rc1-2ubuntu6
+Version: 1:1.1.0~rc1-2ubuntu6
 Architecture: all
+Multi-Arch: foreign
 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
 Installed-Size: 316
 Recommends: libfile-mimeinfo-perl, x11-utils, x11-xserver-utils
3
ответ дан 02.02.2020, 17:24

Теги

Похожие вопросы