'teamviewer зависит от (& hellip;) "при попытке установить TeamViewer [duplicate]

Если я не ошибаюсь, вы также должны запустить соответствующий скрипт оболочки в вашем bashrc.

https://github.com/chriskempson/base16-shell

13
задан 17.04.2020, 06:59

7 ответов

Из строки «замена» выглядит, как будто TeamViewer уже установлен.

Если это не так, запустите (в терминале):

sudo apt-get -f install

, а затем

sudo apt-get install libc6-i386 lib32asound2 lib32z1 ia32-libs

и попробуйте установить .deb с помощью

sudo dpkg -i teamviewer_linux_x64.deb

Если ничего не работает и только если ничего не работает, вы можете форсировать установку, но вы, скорее всего, BREAK APT :

sudo dpkg --force-depends -i teamviewer_linux_x64.deb

Обратите внимание, что это далеко от идеала .

17
ответ дан 17.04.2020, 07:01
  • 1
    Ну, нет, я добавил данные из терминала, который получил некоторую информацию, когда я сделал команды, Вы дали мне. – Phillip Senn 17.04.2020, 07:02
  • 2
    @Teknikk посмотрите редактирования к моему сообщению. Надо надеяться, новые работы команды. В противном случае попробуйте sudo apt-get install ia32-libs-multiarch. – Amol Katdare 17.04.2020, 07:02
  • 3
    Ну, я добрался, это для работы с помощью не вызывает метод, После того, как сделано 3 шага, и получило ошибки, я взял перезапуск и попробовал еще раз, и затем это работало, Таким образом, я могу наконец управлять этим mechine на своем другом. – James Wiseman 17.04.2020, 07:03
  • 4
    Попробованный это, и это возвратило ошибку. tek@tek-G53SW: ~/Download$ sudo склонный - добираются, libc6-i386 lib32asound2 lib32z1 установки ia32-освобождает списки пакета Чтения... Сделанное дерево зависимостей Здания, Чтение информация состояния... Сделанный Вы могли бы хотеть выполнить ' склонный - получают-f install' исправлять их: следующие пакеты не встретили зависимости: ia32-освобождает: Зависит: ia32-libs-multiarch E: невстреченные зависимости. Попробуйте ' склонный - получают-f install' без пакетов (или определяют решение). tek@tek-G53SW: ~/Download$ – Phillip Senn 17.04.2020, 07:03
  • 5
    @Teknikk мое решение работает? – Benjamin 17.04.2020, 07:03

Просто проверьте, установлен ли teamviewer в вашей системе, набрав dpkg -l | grep team

Если вы любезно удалите его полностью, установите поддерживаемые зависимости и переустановите заново, используя sudo dpkg --force-depends -i teamviewer_i386.deb. Эта статья может оказаться полезной. http://bizgolive.com/blog/teamviewer-installation-in-lubuntu-from-command-line-dependency-error-fixed/

0
ответ дан 17.04.2020, 07:00

Это на сайте TeamViewer.

Примечания для Multiarch: На более новых 64-битных DEB-системах с поддержкой Multiarch (Debian 7) teamviewer_linux_x64.deb не может быть установлен, поскольку пакет ia32-libs больше не доступен в этих системах. В этом случае вы можете использовать teamviewer_linux.deb.

В случае, если вы получили ошибку « неправильная архитектура i386 », вам необходимо выполнить следующие командные строки:

dpkg --add-architecture i386

apt-get update

Для получения дополнительной информации: http: // wiki .debian.org / Мультиархитектурная / МЕТОДИЧЕСКИЕ

5
ответ дан 17.04.2020, 07:00

Для Ubuntu 16.04 у меня работали следующие команды

sudo apt-get install libz1:i386 libncurses5:i386 libbz2-1.0:i386 libstdc++6:i386

1
ответ дан 17.04.2020, 07:01
  • 1
    после выполнения вышеупомянутого я тогда должен был работать: ' склонные sudo - получают-f install' Это пробежало и закончило teamviewer установку.Примечание: Я уже выполнил ' команда sudo dpkg-i./teamviewer_13.0.9865_i386.deb прежде, чем сделать все это. – Raynos 17.04.2020, 07:01

Это сработало для меня:

sudo apt-get install gdebi
sudo gdebi TEAMVIEWER_PACKAGE.deb
0
ответ дан 17.04.2020, 07:02

Есть еще один вариант - не самый лучший, но он заставит вас работать в Teamviewer.

Если вы создали учетную запись Teamviewer через их веб-сайт, вы можете использовать веб-логин для удаленного доступа к другим компьютерам - это только внешнее соединение, поэтому вы не можете использовать его, чтобы разрешить кому-либо удаленный доступ к вашему компьютеру, но оно будет по крайней мере, позволит вам получить доступ к другим.

Извините, у вас так много проблем - все ваши новые ошибки выше моей базы знаний. Извините.

0
ответ дан 17.04.2020, 07:02

Я без проблем запускаю teamviewer 7 на ubuntu 12.04 64 bit.

Все, что я сделал для его установки, это загрузил файл прямо с веб-сайта Teamviewer, выбрав правильную версию (то есть Ubuntu 64-битная), и просто открыл файл, и центр программного обеспечения установил его для меня без проблем.

Но, глядя на ваш вывод ошибок, я бы просто установил все недостающие зависимости. Зайдите в Центр программного обеспечения и найдите все недостающие элементы и установите их, прежде чем пытаться снова установить teamviewer. Не забудьте в центре программного обеспечения нажать «Показать технические элементы» в левом нижнем углу экрана.

Надеюсь, это сработает для вас.

Удачи.

2
ответ дан 17.04.2020, 07:03

Теги

Похожие вопросы