ibus-avro не работает в Ubuntu 12.10

Я использовал ibus-avro с методом ввода ibus для написания бенгали в Ubuntu 12.04. Недавно я обновил Ubuntu с 12.04 до 12.10, теперь ibus-avro был удален. Я попытался установить его снова, но получало сообщение об ошибке следующим образом

Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  
The following information may help to resolve the situation:  

The following packages have unmet dependencies:  
ibus-avro : Depends: gir1.2-gjsdbus-1.0 but it is not installable  
0
задан 15.04.2020, 01:44

2 ответа

Наконец-то я смог установить его. Я скомпилировал его из источника без установки gir1.2-gjsdbus-1.0 и до сих пор он работает отлично.
Сначала установите нижеуказанные пакеты, используя код.

sudo apt-get install git ibus libibus-1.0-dev automake autoconf gjs gir1.2-ibus-1.0

Теперь установите следующий код для загрузки, компиляции и установите ibus-avro

git clone git: //github.com/sarim/ibus-avro.git
cd ibus-avro
aclocal & amp ; & амп; autoconf & amp; & amp; automake --add-missing
./configure --prefix = / usr
sudo make install

Я нашел эту инструкцию по этой ссылке [ 119]
https://github.com/sarim/ibus-avro/blob/master/README.md

Вы можете заметить, что я опустил пакет "gir1. 2-gjsdbus-1.0 ", который Сарим сказал в комментарии к проблеме, вы можете проверить его по следующей ссылке
https://github.com/sarim/ibus-avro/issues / 37

Благодарю

3
ответ дан 15.04.2020, 01:45

Я нашел решение отсюда ... просто делайте то, что вам говорят, и компилируйте источники, как описано .... http://forum.linuxdesh.org/thread-1088.html [ 110]

-1
ответ дан 15.04.2020, 01:45
  • 1
    Добро пожаловать для Выяснения у Ubuntu! Пока это может теоретически ответить на вопрос, это было бы предпочтительно , чтобы включать основные части ответа здесь и предоставить ссылку для ссылки. – bdwakefield 15.04.2020, 01:45
  • 2
    Проблема, я не могу установить gir1.2-gjsdbus-1.0 в Ubuntu 12.10. Именно это мой сообщение об ошибке показывает в моем вопросе выше. Любым путем спасибо за Вас комментирует @Nazmus – CarlR 15.04.2020, 01:46

Теги

Похожие вопросы